Please note that we have switched to an alternative provider to keep services running. Most transactions are now processing normally, though a few users may still see slight delays.
We apologize for the trouble and are monitoring the situation closely.
Affected Services: Affected Markets: Kenya
Posted Mar 12, 2026 - 09:11 UTC
Update
Please note that we have switched to an alternative provider to keep services running. Transactions are now processing normally.
We apologize for the trouble and are monitoring the situation closely.
Affected Services: Affected Markets: Kenya
Posted Mar 12, 2026 - 09:02 UTC
Identified
Dear Valued Customer,
We are aware that some users are having trouble with M-Pesa payments. This is due to a technical issue with our service provider. Our team is working with them to fix this quickly. We apologize for the trouble.
Affected Services: Affected Markets: Kenya
Posted Mar 12, 2026 - 07:56 UTC
This incident affects: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).