Service Restored: Name Enquiry and Notification Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting Name Enquiry and Notification services has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Aug 31, 2026 - 22:48 UTC

Identified

Dear Valued Merchant,

We are experiencing a disruption affecting Name Enquiry and Notification services. As a result, some customers may be unable to verify recipient names before completing transactions, and transaction notifications may be delayed.

Our team is actively working to restore normal service. We will share further updates as progress is made.

We apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Aug 31, 2026 - 15:55 UTC
This incident affected: Flutterwave Collections (Collections APIs).