[Europe] Service Restored: Delayed EUR Transfers

Incident Report for Flutterwave

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 14:42 UTC

Update

Dear Valued Customer,

We are facing a temporary issue with an external EUR payment provider. Some customers may notice that their transfers are pending longer than usual. We are working on a fix to get everything back to normal. We apologize for the inconvenience and thank you for your patience.
Posted Jun 23, 2026 - 08:19 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 23, 2026 - 08:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 23, 2026 - 08:08 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).