Scheduled System Maintenance on MTN Ghana, 4th September 2025

Incident Report for Flutterwave

Resolved

Dear valued customer,

We are pleased to let you know that the maintenance on the MTN Ghana has been successfully completed.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Ghana
Posted Sep 08, 2025 - 08:51 UTC

Identified

Dear Valued Customer,

Please be aware of an upcoming planned maintenance for MTN Mobile Money (MoMo) Ghana.

Maintenance Schedule:

Start: Thursday, 4th September 2025, 05:00 PM UTC
End: Friday, 5th September 2025, 04:00 AM UTC

You may experienced service disruptions during this period.

We sincerely apologize for any disruption this may cause and appreciate your understanding.

Thank you for your continued support.

Affected Services:
Affected Markets: Ghana
Posted Sep 04, 2025 - 10:54 UTC
This incident affected: Flutterwave Collections (Checkout JS).