[Nigeria] Service Alert: Issues with Name Verification

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with name enquiry service has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted May 05, 2026 - 06:30 UTC

Identified

Dear Valued Customer,

Our name enquiry service is currently down due to a third-party issue. This may not affect all users, but we are working hard to resolve it as quickly as possible. We apologize for the disruption to your day.

Affected Services:
Affected Markets: Nigeria
Posted May 04, 2026 - 20:03 UTC
This incident affected: Flutterwave Collections (Collections APIs).