[First Bank] Nigeria - Late response to transfer requests
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 09:43 UTC
Investigating
NIP transactions to First bank are failing intermittently.

Challenge: Late response to transaction requests

First Bank's technical team is currently working to resolve the challenge.

An update will be provided once this is resolved.
Posted Jun 01, 2021 - 10:27 UTC
This incident affected: Dashboard and Collections.