[Nigeria] Service Restored: Name Enquiry Service Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue with Name Enquiry service has been successfully resolved.

Thank you for your patience and understanding.
Posted Jul 25, 2026 - 06:30 UTC

Investigating

Dear Valued Merchant,

Due to a partner issue, some customers may be unable to verify recipient names before completing transactions. You may also notice lower transaction activity while the disruption persists.

The affected provider has been notified, and we are working closely with them to restore normal service. We will share further updates as they become available.

We apologize for the inconvenience and thank you for your continued understanding.
Posted Jul 24, 2026 - 12:05 UTC
This incident affected: Flutterwave Collections (Collections APIs).