Card Payments Experiencing Delays, Sept 11, 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customers,

We are happy to report that the service disruption affecting card payments has been fully resolved. All transactions are now processing normally.

Thank you for your patience and understanding while we worked to fix this issue. We apologize again for any inconvenience this may have caused.

Affected Services:
Affected Markets: Nigeria
Posted Sep 11, 2025 - 19:01 UTC

Identified

Dear Valued Customers,

We are currently experiencing a service disruption with our card payment processing, which is affecting transactions. We are aware that some transactions may be timing out.

Our technical team is working closely with our provider to resolve this issue as quickly as possible. We will keep you updated on the progress.

We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Sep 11, 2025 - 16:00 UTC
This incident affected: Flutterwave Collections (Collections APIs).