[Rwanda] Service Restored: Issues with Collections and Payouts

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the intermittent failures with collections and payouts in Rwanda has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Rwanda
Posted May 01, 2026 - 14:32 UTC

Identified

Dear Valued Customer,

We are seeing intermittent failures with our payment partner in Rwanda. Some users may have trouble with collections and payouts. Our team is investigating the cause and working on a fix. We are sorry for the trouble.

Affected Services:
Affected Markets: Rwanda
Posted May 01, 2026 - 09:26 UTC
This incident affected: Flutterwave Collections (Collections APIs).