We are pleased to inform you that the service disruption impacting access and response times for some payment and connectivity services has been successfully resolved. We are monitoring the situation closely to ensure continued stability. Thank you for your patience and understanding.
Affected Services: Affected Markets: Nigeria
Posted Nov 12, 2025 - 09:47 UTC
Identified
Dear Valued Customer,
We are currently experiencing a service disruption impacting access and response times for some of some payment and connectivity services.
Our technical team is actively investigating the cause of the downtime and working diligently to restore full service immediately.
We will provide an update as soon as we have more information.
We apologize for any interruption this may cause to your operations.
Affected Services: Affected Markets: Nigeria
Posted Nov 12, 2025 - 09:24 UTC
This incident affected: Flutterwave for Business (Dashboard).