[Global] Service Restored: Mastercard Service Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the service disruption affecting Mastercard transactions across all regions has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Jul 15, 2026 - 12:18 UTC

Identified

Dear Valued Merchant

We are currently experiencing a service disruption affecting Mastercard transactions across all regions. As a result, some customers may experience failed or delayed transactions.

We are actively working with Mastercard to restore normal service as quickly as possible. We will continue to provide updates as more information becomes available.

We apologize for the disruption and appreciate your understanding.

Affected Services:
Affected Markets: Global
Posted Jul 15, 2026 - 08:39 UTC
This incident affected: Flutterwave Collections (Checkout JS).