Inability to Login on F4B Dashboard
Incident Report for Flutterwave
Resolved
Hi esteemed merchants,

We wish to inform you that you can now log into the F4B dashboard.

We sincerely apologize for any inconvenience this downtime may have caused.

Affected Services: F4B Login & Dashboard
Affected Markets: Global
Posted Mar 12, 2024 - 10:27 UTC
Investigating
Hi esteemed merchants,

We wish to inform you that we are aware of the current inability to log in on the F4B dashboard. Our engineers are currently working to resolve and bring the service back up.

We apologize for any inconvenience this may have caused.

Affected Services: F4B Login & Dashboard
Affected Markets: Global
Posted Mar 12, 2024 - 10:13 UTC
This incident affected: Flutterwave for Business (Dashboard).