Service Restored: Transaction Notifications, Bank Account Verification

Incident Report for Flutterwave

Resolved

Dear All,

We are pleased to inform you that the service disruption impacting our connection with a banking partner has been successfully resolved. Thank you for your patience and understanding

Affected Services:
Affected Markets: Nigeria
Posted Nov 06, 2025 - 15:54 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption impacting our connection with a banking partner.

The primary impact you may notice is:

Delayed Transaction Notifications: After a transaction is completed, you may not receive an immediate confirmation or notification. The transaction is processing, but the notification is slow.

Temporary Issues with Bank Account Name Verification.

This issue is originating from our provider, and our technical team is actively working with them to ensure a swift resolution.

We apologize for any inconvenience caused and will provide an update as soon as the issue is resolved.

Affected Services:
Affected Markets: Nigeria
Posted Nov 06, 2025 - 14:09 UTC
This incident affected: Flutterwave Collections (Collections APIs).