[Kenya] Service Restored: Payment Processing Delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that this issue has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Jul 06, 2026 - 12:16 UTC

Update

KES credit payments have been restored and are processing successfully. Delays affecting customer debit payments are still ongoing as we continue working with our external service provider to resolve the issue.

We apologize for the inconvenience and appreciate your patience.

Affected Services:
Affected Markets: Kenya
Posted Jul 06, 2026 - 08:38 UTC

Identified

Dear Cherished Merchant,

We are currently experiencing a service disruption affecting some merchants in Kenya due to an issue with one of our external service providers. As a result, customers may experience delays when making debit payments or receiving credit payments.

Our team is working closely with the provider to restore normal service as quickly as possible. We will continue to share updates as more information becomes available.

We sincerely apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Jul 06, 2026 - 07:49 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).