Issue with Sterling PWBT, 25th August 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the issue with Sterling pay with bank transfer has been resolved. You can now make payments without any disruption.

Thank you for your patience and understanding while we worked to fix this. We apologize for any inconvenience this may have caused.

Affected Services:
Affected Markets: Nigeria
Posted Aug 28, 2025 - 08:37 UTC

Update

Dear Valued Customer

The issue with Sterling pay with bank transfer is still ongoing. Our team is actively working with our provider to resolve this as quickly as possible.

In the meantime, you can continue to use WEMA pay with bank transfer without any issues.

We apologize for the continued inconvenience and will provide another update as soon as we can.

Affected Services: Sterling Bank PWBT
Affected Markets: Nigeria
Posted Aug 27, 2025 - 07:40 UTC

Investigating

Dear Valued Customer,

We are writing to provide an update on the ongoing service disruption with Sterling pay with bank transfer. Our provider is still actively working to resolve the issue.

While this disruption continues, we want to assure you that you can still make payments without interruption using WEMA pay with bank transfer. We have temporarily switched to this provider to ensure your payment process remains smooth and uninterrupted.

We sincerely apologize for any continued inconvenience this may cause and appreciate your patience as we work to get this resolved. We will notify you as soon as we have another update.

Affected Services: Sterling Bank PWBT
Affected Markets: Nigeria
Posted Aug 26, 2025 - 12:06 UTC

Identified

Dear Valued Customers,

Please be aware that we are currently experiencing a service disruption with Sterling pay with bank transfer.

While our provider works to resolve this, we have temporarily switched to WEMA pay with bank transfer to ensure you can continue to make payments without interruption.

We sincerely apologize for any inconvenience this may cause and will provide an update as soon as they are available

Thank you for your patience and understanding.

Affected Services: Sterling Bank PWBT
Affected Markets: Nigeria
Posted Aug 25, 2025 - 10:05 UTC
This incident affected: Flutterwave Collections (Collections APIs).