Scheduled Maintenance, MTN UGANDA, Sep 13 2025

Incident Report for Flutterwave

Update

Dear Valued Customer,

Please be informed about a system upgrade on MTN Mobile Money, Uganda.

Maintenance Schedule:
Start: Sunday, September 13th 2025, 11:00 PM UTC
End: Sunday, September 14th 2025, 07:00 AM UTC

During this time, you may experience interruptions on MTN MoMo services.

We apologize for any inconvenience this may cause and appreciate your understanding.

Affected Services:
Affected Markets: Uganda
Posted Sep 13, 2025 - 06:56 UTC

Identified

Dear Valued Customer,

Please be informed about a system upgrade on MTN Mobile Money, Uganda.

Maintenance Schedule:
Start: Sunday, September 14th 2025, 11:00 PM UTC
End: Sunday, September 14th 2025, 07:00 AM UTC

During this time, you may experience interruptions on MTN MoMo services.

We apologize for any inconvenience this may cause and appreciate your understanding.

Affected Services:
Affected Markets: Uganda
Posted Sep 13, 2025 - 06:54 UTC
This incident affects: Flutterwave Collections (Collections APIs).