[Nigeria] Service Restored: Card transaction issues

Incident Report for Flutterwave

Resolved

We are pleased to inform you that this issue has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 01, 2026 - 07:38 UTC

Identified

Dear Valued Customer,

A third-party provider is experiencing an issue that may prevent some customers from completing card payments. We are investigating and doing everything we can to restore normal service soon.
We apologize for the inconvenience and appreciate your support while we work on a fix.

Affected Services:
Affected Markets: Nigeria
Posted Jun 30, 2026 - 18:05 UTC
This incident affected: Flutterwave Collections (Collections APIs).