We are pleased to confirm that the scheduled maintenance on our payment rail has been successfully completed.
The processing of SEPA Instant Payments (inbound and outbound) and GBP Payouts is now fully restored and operating as normal.
All services are fully operational.
Thank you for your patience and understanding.
Affected Services: Affected Markets: Europe
Posted Oct 05, 2025 - 13:38 UTC
Identified
Dear Valued Customer,
We wish to inform you of a scheduled maintenance on a payment rail that will temporarily affect the processing of GBP Payouts and SEPA Instant Payments.
Start Time: Sunday, 5th October 2025, 02:00 AM UTC End Time: Sunday, 5th October 2025, 02:30 AM UTC
During this 30-minute window, the processing of both inbound and outbound SEPA Instant Payments and GBP Payouts will be temporarily unavailable.
All other services remain fully operational. We apologize for any inconvenience this brief, necessary maintenance may cause and appreciate your understanding.
Affected Services: Affected Markets: Europe
Posted Oct 03, 2025 - 05:43 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).