Issue accessing checkout

Incident Report for Flutterwave

Resolved

We are pleased to inform you that this has been successfully resolved.

We thank you for your patience and understanding.


Affected Services:
Affected Markets: Global
Posted Jun 25, 2026 - 16:44 UTC

Identified

Dear Valued Customer,

We are currently addressing a technical issue that is preventing some customers from completing transactions at checkout. We are actively investigating the cause and are focused on resolving this immediately. We apologize for the trouble this causes and thank you for your understanding.

Affected Services:
Affected Markets: Global
Posted Jun 25, 2026 - 15:47 UTC

Investigating

Dear Valued Customer,

We are currently addressing a technical issue that is preventing some customers from completing transactions at checkout. We are actively investigating the cause and are focused on resolving this immediately. We apologize for the trouble this causes and thank you for your understanding.

Affected Services:
Affected Markets: Global
Posted Jun 25, 2026 - 15:47 UTC
This incident affected: Flutterwave Collections (Checkout JS).