Internittent Issue with Wema PWBT, 25th August 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the intermittent delay in notifications with WEMA pay with bank transfer has been successfully resolved.

Thank you for your patience and understanding.

Affected Services: WEMA Bank PWBT
Affected Markets: Nigeria
Posted Aug 26, 2025 - 09:26 UTC

Identified

Dear Valued Customer,
We are experiencing intermittent delayed transaction notifications from WEMA Bank pay with bank transfer. While account generation and payment processing are successful, there is delay in transaction notifications.

Our team is working with the provider to restore normal operations. We will provide an update as soon as they are available.

We apologize for the inconveniences experienced and appreciate your patience and understanding.

Affected Services: WEMA Bank PWBT
Affected Markets: Nigeria
Posted Aug 25, 2025 - 13:42 UTC
This incident affected: Flutterwave Collections (Collections APIs).