Service Restored - Virtual Account Creation

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the degraded performance in our Virtual Account Number (VAN) Creation service has been successfully resolved. Thank you for your patience and understanding

Affected Services:
Affected Markets: Nigeria
Posted Nov 04, 2025 - 15:24 UTC

Identified

Dear Valued Customer,

We are observing degraded performance in our Virtual Account Number (VAN) Creation service due to an issue with an external service partner.

Some users may experience a significantly high failure rate when attempting to create new accounts.

We are actively investigating the situation and collaborating with our partner to implement a fix. Thank you for your patience during this necessary external resolution.

Affected Services:
Affected Markets: Nigeria
Posted Nov 04, 2025 - 15:22 UTC
This incident affected: Flutterwave Collections (Collections APIs).