Service Restored: Uganda Momo Payout

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption affecting Uganda MoMo Payout has been successfully resolved. Transactions are now processing normally without timeouts.

Thank you for your patience and understanding while we worked with our partner to restore full service.

Affected Services:
Affected Markets: Uganda
Posted Oct 16, 2025 - 11:40 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption affecting our Uganda MoMo Payout causing timeouts on transactions.
The partner is actively working to restore full service.
Further update will be shared as soon as possible.

We apologize for the inconvenience this may cause and appreciate your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Oct 16, 2025 - 07:58 UTC
This incident affected: Flutterwave Collections (Collections APIs).