Service Restored: Delays with Mobile Money Transactions (Uganda)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the technical issue with one of our service providers in Uganda has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Mar 10, 2026 - 07:13 UTC

Identified

Dear Valued Customer,

We are currently experiencing a technical issue with one of our service providers in Uganda. This may cause delays for some users trying to make collections or payouts.

Our partner is working on a fix, and we will update you soon. We apologize for the trouble.

Affected Services:
Affected Markets: Uganda
Posted Mar 08, 2026 - 19:03 UTC
This incident affected: Flutterwave Collections (Collections APIs).