[Nigeria] Service Alert: Fidelity Bank Service Disruption

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting Dynamic Account generation has been successfully resolved.

Thank you for your patience and understanding.
Posted Aug 12, 2026 - 09:05 UTC

Investigating

Dear Valued Merchant,

Fidelity Bank is currently experiencing a disruption affecting Dynamic Account generation in Nigeria. Customers attempting to generate a Dynamic Account may therefore be unable to complete the process.

We have engaged the Bank and are awaiting further information as they work to resolve it. We will keep you informed of any updates.

We apologize for the inconvenience and appreciate your understanding.
Posted Aug 12, 2026 - 08:04 UTC