[NGN] Service Restored: Disruption on NGN Card Collections through Interswitch

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting NGN card collections through Interswitch has been resolved, and normal service has been restored.

We apologize for the inconvenience experienced and appreciate your continued understanding.

Affected Services:
Affected Markets: Nigeria
Posted Sep 24, 2026 - 13:36 UTC

Identified

Dear Valued Merchant,

We are currently seeing a disruption affecting some NGN card collections through Interswitch, which may prevent transactions from completing successfully. The service provider has been notified and we are working to restore normal service. Further updates will be shared as progress is made.

We apologize for the inconvenience and thank you for your patience.

Affected Services:
Affected Markets: Nigeria
Posted Sep 24, 2026 - 06:58 UTC
This incident affected: Flutterwave Collections (Collections APIs).