[Global] Service Alert: Processing Delay on USD Card Payouts

Incident Report for Flutterwave

Resolved

We are please to inform you this issue has been resolved
Thank you for your patience and understanding
Posted Sep 10, 2026 - 12:09 UTC

Investigating

Dear Valued Merchant,

Please be advised that we are currently experiencing delays with USD Card Transfers and Payouts,
Our team is working to resolve this with the partner provider, and will keep you updated.
We apologize for the inconvenience.
Posted Sep 10, 2026 - 12:06 UTC
This incident affected: Flutterwave Payouts (Payouts APIs).