Service Restored: Pay With Bank Transfer Rail

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption affecting our Pay with Bank Transfer (PWBT) rail has been successfully resolved.

Transaction processing, account number generation, and notification delivery are all functioning normally.

Thank you for your patience and understanding while we worked to restore full service.


Affected Services:
Affected Markets: Nigeria
Posted Oct 20, 2025 - 10:30 UTC

Identified

Dear Valued Customer,

We are currently experiencing a service disruption affecting one of our Pay with Bank Transfer (PWBT) rail. As a result:

Transactions are currently failing

The Name Enquiry service is impacted

Customers are unable to generate account numbers

Notification delivery may be delayed

Our engineering team is actively working with relevant partners to restore full service as quickly as possible.
We will continue to provide updates as more information becomes available.

We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Oct 20, 2025 - 08:19 UTC
This incident affected: Flutterwave Collections (Collections APIs).