Service Alert: Transaction Timeout Error

Incident Report for Flutterwave

Update

We are continuing to monitor for any further issues.
Posted May 10, 2026 - 05:49 UTC

Monitoring

Dear Valued Customer,

We are pleased to inform you that this has been successfully resolved. We are monitoring the situation closely to ensure continued stability.

Thank you for your patience and understanding.
Posted May 10, 2026 - 05:48 UTC

Identified

Dear Valued Customer,

You may notice some errors or "timeouts" when trying to complete a payment. We are aware of the problem and our engineers are working hard to resolve it. We truly apologize for any inconvenience this has caused.
Posted May 10, 2026 - 05:39 UTC
This incident affects: Flutterwave Payouts (Payouts APIs), Flutterwave Website, Flutterwave for Business (Flutterwave API), and Flutterwave Collections (Collections APIs).