[Kenya] Service Restored: KES Payment Delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that this has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Jul 10, 2026 - 07:33 UTC

Identified

Dear Cherished Merchant

We are currently experiencing a service disruption affecting an external service provider. As a result, some merchants may experience delays in receiving payments.

We are working closely with them to restore normal service as quickly as possible and will provide further updates as they become available.

We apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Jul 09, 2026 - 12:13 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).