[Kenya] Service Restored: Temporary Payment and Transfer Delays

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruptions affecting some payment and transfer services in Kenya has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Uganda
Posted Jun 10, 2026 - 06:24 UTC

Identified

Dear Valued Customer,

We are currently experiencing a payment processing issue with one of our network providers in Uganda. Because of this, some deposits may fail or take longer than usual to reflect. Our team is actively investigating the issue to get things back to normal.
We apologize for the inconvenience and thank you for your patience.

Affected Services:
Affected Markets: Uganda
Posted Jun 09, 2026 - 22:02 UTC
This incident affected: Flutterwave Collections (Collections APIs).