[EGYPT] Service Alert: Collection Issues

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the issue with Collections has been successfully resolved.

Thank you for your patience and understanding.
Posted Jul 03, 2026 - 16:50 UTC

Investigating

Dear Valued Customer,

We are currently experiencing a temporary service disruption affecting collection transactions within the Egypt corridor.

We are actively working to resolve this issue. Further updates will be provided as soon as possible.

We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding.
Posted Jul 03, 2026 - 15:44 UTC
This incident affected: Flutterwave Collections (Collections APIs).