Service Restored: Payouts and Stablecoin Onboarding

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting F4B payout processing and stablecoin onboarding has been resolved, and normal service has been restored.

We apologize for the inconvenience experienced and appreciate your continued

Affected Services:
Affected Markets: Global
Posted Sep 17, 2026 - 16:03 UTC

Update

Please note that payout transactions are processing successfully, but some may experience delays. Our team is actively working to restore normal processing times.

We appreciate your patience and understanding.
Posted Sep 17, 2026 - 09:32 UTC

Identified

Dear Valued Merchant,

We are currently experiencing a disruption affecting F4B payout processing and stablecoin onboarding, which may prevent some transactions and onboarding activities from completing successfully. Our teams are actively investigating the affected services and working to restore normal service. Further updates will be shared as progress is made.

We apologize for the inconvenience and thank you for your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Sep 17, 2026 - 09:03 UTC
This incident affected: Flutterwave for Business (Flutterwave API).