Dear All, We would like to inform you the login issues on the F4B platform has been completely resolved We sincerely apologize for the inconvenience experienced during this period Thank you for understanding
Posted May 27, 2025 - 09:02 UTC
Update
Dear All,
We would like to provide you with an update regarding the recent login issues on the F4B platform.
Access to the platform has been largely restored, however, some users may still experience intermittent issues.
If you encounter difficulties logging in, we recommend retrying, as most users are able to gain access after one or more attempts.
We sincerely apologize for the inconvenience and appreciate your continued patience as we work to fully resolve the issue.
Thank you for your understanding.
Affected Services: F4B Login & Dashboard Affected Markets: Global
Posted May 26, 2025 - 08:24 UTC
Identified
Dear Valued Customer,
We are currently experiencing an issue on Flutterwave for Business (F4B) that is preventing some users from logging onto the platform. Our engineers are actively investigating the situation and working diligently to resolve it as quickly as possible.
We sincerely apologize for any inconvenience this may be causing and appreciate your patience and understanding during this time. We are committed to keeping you informed and will provide updates as soon as they become available.
Thank you for your continued support.
Affected Services: F4B Login & Dashboard Affected Markets: Global
Posted May 24, 2025 - 16:16 UTC
This incident affected: Flutterwave for Business (Dashboard).