Service Restored: Card Collection Services (Nigeria)

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the service disruption impacting our card payment collection services in Nigeria has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Nov 26, 2025 - 14:39 UTC

Identified

Dear Valued Customer,

We are currently observing a service disruption impacting our card payment collection services in Nigeria.

We are actively working with our partner to resolve the cause of this issue.

We apologize for any inconvenience experienced and will provide an update as soon as more information is available.

Affected Services:
Affected Markets: Nigeria
Posted Nov 26, 2025 - 12:49 UTC
This incident affected: Flutterwave Collections (Collections APIs).