[Nigeria] Service Restored: Intermittent Disruption Affecting Wema Bank Payments

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the disruption affecting Wema pay with Bank transfer has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 11, 2026 - 22:33 UTC

Identified

Dear Valued Merchant,

We are currently experiencing a disruption affecting Wema pay with Bank transfer. As a result, some customers may be unable to confirm the recipient's name before making a payment, and transaction notifications may be delayed.

This issue is related to Wema Bank, and we are actively working with them to restore normal service as quickly as possible.

We apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 11, 2026 - 22:12 UTC
This incident affected: Flutterwave Collections (Collections APIs).