Please note that the scheduled maintenance by MasterCard has been rescheduled.
We will provide more information on the new maintenance date as soon as we have more information.
Thank you for your continued support.
Affected Services: Affected Markets: US
Posted Oct 09, 2025 - 07:41 UTC
Update
Dear Valued Customer,
Please be advised of a scheduled maintenance on the Mastercard Gateway and Regional Service Center (North America region).
What to Expect During the Maintenance Windows: Intermittent Impact: Customers may experience brief (approx. 15 second) periods of increased transaction timeouts and/or failed transactions.
Draft Capture File (DCF) Delay: Delays in the delivery of the DCF file (up to 20 minutes) may occur.
Maintenance Schedule (UTC - Coordinated Universal Time): Window 1: Thursday, 23rd October 2025, 05:30 AM – 06:30 AM UTC
Window 2: Thursday, 23rd October 2025, 07:30 AM – 9:30 AM UTC
We apologize for any inconvenience this maintenance may cause and appreciate your understanding. We will monitor the situation closely during these times.
Affected Services: Affected Markets: US
Posted Oct 03, 2025 - 15:07 UTC
Identified
Dear Valued Customer,
Please be advised of a scheduled maintenance on the Mastercard Gateway and Regional Service Center (North America region).
What to Expect During the Maintenance Windows: Intermittent Impact: Customers may experience brief (approx. 15 second) periods of increased transaction timeouts and/or failed transactions.
Draft Capture File (DCF) Delay: Delays in the delivery of the DCF file (up to 20 minutes) may occur.
Maintenance Schedule (WAT - West Africa Time): Window 1: Thursday, 23rd October 2025, 05:30 AM – 06:30 AM UTC
Window 2: Thursday, 23rd October 2025, 07:30 AM – 9:30 AM UTC
We apologize for any inconvenience this maintenance may cause and appreciate your understanding. We will monitor the situation closely during these times.
Affected Services: Affected Markets: US
Posted Oct 03, 2025 - 15:05 UTC
This incident affected: Flutterwave Collections (Checkout JS).