Service Restored: Intermittent Payment Delays (Nigeria)

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the timeouts issue due to an issue with one of our network partners has been successfully resolved.

We thank you for your patience and understanding.


Affected Services:
Affected Markets: Nigeria
Posted Apr 15, 2026 - 12:18 UTC

Identified

Dear Valued Customer,

Some users may experience timeouts when performing transactions due to an issue with one of our network partners. We are investigating the cause and will provide an update shortly.

Affected Services:
Affected Markets: Nigeria
Posted Apr 15, 2026 - 10:48 UTC
This incident affected: Flutterwave Collections (Collections APIs).