Nigeria Service Alert: Issue with Name Enquiry Service

Incident Report for Flutterwave

Resolved

We are pleased to infor you that the disruption affecting some transactions in Nigeria has been successfully resolved.

Thank you for your patience and understanding.
Posted Aug 11, 2026 - 06:40 UTC

Investigating

Dear Valued Merchant,

We are currently experiencing a disruption affecting some transactions in Nigeria. Customers may be unable to verify the recipient’s name before completing a payment.

The issue is related to a service provider, and we are actively working with them to restore normal service. We will share further updates as more information becomes available.

We apologize for the disruption and appreciate your patience and understanding.
Posted Aug 10, 2026 - 15:17 UTC