Service Restored: Delays in KES Rail Payment Confirmations

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the disruption with our KES Collections service, resulting in delays and failures to receive final transaction confirmations has been successfully resolved. Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Dec 12, 2025 - 22:24 UTC

Update

Please note that the service provider is actively working on a resolution. We will share an update as soon as we have more information. We apologize for the inconvenience.

Affected Services:
Affected Markets: Kenya
Posted Dec 12, 2025 - 09:17 UTC

Identified

Dear Valued Customer,

We are experiencing a disruption with our KES Collections service, resulting in delays and failures to receive final transaction confirmations. We are actively reviewing this and working toward a resolution. We apologize for the inconvenience.

Affected Services:
Affected Markets: Kenya
Posted Dec 12, 2025 - 06:32 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).