[Nigeria] Service Alert: Issue with Name Verification

Incident Report for Flutterwave

Resolved

The issue impacting recipient name verification has been successfully resolved.

Thank you for your patience and understanding
Posted Aug 20, 2026 - 11:58 UTC

Investigating

Dear Valued Merchant,

A disruption affecting a partner is currently impacting recipient name verification. This means some merchants may be unable to confirm the intended recipient before completing a payment.

We are engaging the partner to address the issue and restore the service as soon as possible. Further updates will be shared when available.

We apologize for the inconvenience and appreciate your continued patience.
Posted Aug 20, 2026 - 08:59 UTC