Please note that this incident has been resolved and we are closely monitoring all services.
Sincere apologies for all inconveniences experienced during this downtime.
Thank you very much.
Posted Jun 25, 2025 - 09:22 UTC
Identified
Dear Valued Merchants,
Please note that we are still having issues with Flutterwave for Business (F4B) which is also affecting a number of services like USSD collections, Send App, etc. We understand how this affect your business and we sincerely apologise for this inconvenience.
Our Engineers are actively working on resolving this issue and updates will be shared as quickly as possible.
Apologies once again for any inconveniences experienced
Posted Jun 24, 2025 - 17:42 UTC
Investigating
Dear Valued Customer,
We are currently experiencing intermittent timeouts on the Flutterwave for Business (F4B) platform, which may temporarily affect your ability to access and use the application.
Our engineering team is actively investigating the issue to identify the root cause and restore full functionality as quickly as possible. We will provide an update as soon as more information is available.
We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding.
Affected Services: F4B Login & Dashboard Affected Markets: Global
Posted Jun 24, 2025 - 16:53 UTC
This incident affected: Flutterwave Payouts (Payouts APIs), Remittance Products (SendApp), Flutterwave for Business (Flutterwave API, Dashboard), and Flutterwave Collections (USSD Collections).