We are pleased to inform you that the disruption affecting mobile money payments in Rwanda has been fully resolved. Transactions are now processing successfully, and services have returned to normal.
We sincerely apologize for any inconvenience caused during the downtime and appreciate your patience and understanding as we worked with our partner to restore full functionality.
Affected Services: Affected Markets: Rwanda
Posted Oct 24, 2025 - 06:15 UTC
Identified
Dear Valued Customer,
We are currently experiencing a disruption affecting mobile money payments in Rwanda, resulting in a high number of failed transactions.
Our technical teams are actively working closely with our partner to restore full functionality as quickly as possible.
We apologize for any failed attempts and inconvenience this may be causing.
Affected Services: Affected Markets: Rwanda
Posted Oct 17, 2025 - 20:59 UTC
This incident affected: Flutterwave Collections (Collections APIs).