Email OTP Delivery Issue, 9th April 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We would like to inform you that this issue has been resolved and OTPs via emails are being delivered

Thank you for your understanding and continued support.


Affected Services: Email Notification, Email OTP
Affected Markets: Global
Posted Apr 09, 2025 - 12:32 UTC

Investigating

Dear Valued Customer,

We would like to inform you that we are currently experiencing an issue with the delivery of login OTPs via email.

Our technical team is actively investigating the matter and working to implement a resolution as swiftly as possible.

We will keep you updated and notify you once the issue has been fully resolved.

Thank you for your understanding and continued support.

Affected Services: Email Notification, Email OTP
Affected Markets: Global
Posted Apr 09, 2025 - 09:48 UTC
This incident affected: Shared Services (OTP Services).