We are pleased to inform you that the issue affecting OTP delivery on WhatsApp, specific to some merchants has been successfully resolved. We apologize for the experience and appreciate your patience and understanding.
Affected Services: Affected Markets: Rwanda
Posted Oct 17, 2025 - 07:21 UTC
Update
Dear Valued Customer,
We discovered that some of the issues with OTP delivery through WhatsApp are device related. Based on guidance from our provider, we recommend checking the following to ensure successful OTP receipt: The recipient’s phone number is registered on WhatsApp. The recipient has accepted WhatsApp’s latest Terms of Service and Privacy Policy. The recipient is using the latest version of the WhatsApp app. Following several tests, we can confirm that OTPs are now being successfully delivered. Further testing is underway, and we will share additional updates as needed. We sincerely apologize for any inconvenience this may have caused and appreciate your continued patience.
Affected Services: Affected Markets: Rwanda
Posted Oct 15, 2025 - 14:30 UTC
Identified
Dear Valued Customer,
We are currently aware of an issue affecting the delivery of One-Time Passwords (OTPs) to some whatsapp mobile numbers in Rwanda. We are working with our partner provider to resolve as quickly as possible. We understand how important timely OTP delivery is to your experience, and we sincerely apologize for any inconvenience this may have caused. We will share updates as soon as possible. Thank you for your patience and understanding.
Affected Services: Affected Markets: Rwanda
Posted Oct 13, 2025 - 15:42 UTC
This incident affected: Flutterwave Collections (Collections APIs).