Issue with WEMA PWBT, 12th March 2025

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are aware that you may have experienced a service disruption some minutes ago.. This is due to a technical issue, However, this has been resolved.

We sincerely apologize for any inconvenience this may have caused and appreciate your patience.

Affected Services: WEMA Bank PWBT
Affected Markets: Nigeria
Posted Mar 12, 2025 - 17:35 UTC
This incident affected: Flutterwave Collections (Collections APIs).