Issues with Virtual Cards
Incident Report for Flutterwave
Resolved
This incident has been resolved.
Posted Nov 19, 2020 - 09:50 UTC
Identified
We are currently experiencing downtime on all card operations.

The affected card range are the ones starting with 400845xxxxxxx.
We are working with the issuing partner to resolve this shortly and we will keep you updated.
Posted Nov 18, 2020 - 12:50 UTC
This incident affected: Flutterwave for Business (Virtual Cards).