Temporary GHS Payout Issues on F4B, 19th June, 2026

Incident Report for Flutterwave

Resolved

Dear Valued Customer,

We are pleased to inform you that the technical difficulties regarding account validation for payouts on our GHS corridor have been successfully resolved.

Our engineering team has implemented a fix, and normal payout processing has resumed. We are currently closely monitoring the system to ensure continued stability and performance.

Thank you again for your patience and understanding while we worked through this.

Affected Services:
Affected Markets: Global
Posted Jun 19, 2026 - 18:31 UTC

Identified

Dear Valued Customer,

We are currently experiencing technical difficulties with account validation for payouts on our GHS corridor on F4B.

We understand how critical seamless transactions are to your business, and we sincerely apologise for any inconvenience or disruption this may cause. Please be assured that our engineering team is actively working to resolve this issue and restore normal payout processing as quickly as possible.

We are closely monitoring the situation and will send you an update as soon as the issue is fully resolved

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Global
Posted Jun 19, 2026 - 16:09 UTC
This incident affected: Flutterwave for Business (Flutterwave API).