[Kenya] Service Restored: Delays Receiving KES Payments via JamboPay

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the issue affecting JamboPay has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Jul 13, 2026 - 06:59 UTC

Identified

Dear Valued Merchant,

We are currently experiencing a service disruption affecting JamboPay. As a result, some merchants may experience delays receiving KES payments.

The issue has been reported to JamboPay, and we are working closely with them to restore normal service as quickly as possible.

We will continue to share updates as more information becomes available.

We sincerely apologize for the disruption and appreciate your patience and understanding.

Affected Services:
Affected Markets: Kenya
Posted Jul 12, 2026 - 21:45 UTC
This incident affected: Flutterwave Payouts (Payouts APIs) and Flutterwave Collections (Collections APIs).