Service Restored: Delays with First Bank GHS Account Generation

Incident Report for Flutterwave

Resolved

We are pleased to inform you that the delays with First Bank GHS account generation has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Ghana
Posted Apr 16, 2026 - 15:10 UTC

Identified

Dear Valued Customer,

Some users may face issues generating GHS accounts due to a service disruption from our external provider.

We are monitoring the situation closely and will provide an update once it is resolved. Thank you for your patience.

Affected Services:
Affected Markets: Ghana
Posted Apr 16, 2026 - 09:30 UTC
This incident affected: Flutterwave Collections (Collections APIs).