[Nigeria] Service Restored: Name Enquiry Service Failure

Incident Report for Flutterwave

Resolved

We are pleased to inform you that this issue has been successfully resolved.

Thank you for your patience and understanding.

Affected Services:
Affected Markets: Nigeria
Posted Jul 07, 2026 - 15:06 UTC

Identified

Dear Valued Merchant,

We are currently experiencing a service disruption affecting Pay with Bank Transfer transactions through one of our partners. As a result, some customers may be unable to verify recipient details before completing their transactions.

Our team is working closely with the affected partner to resolve the issue and restore normal service as quickly as possible. We will continue to provide updates as more information becomes available.

We sincerely apologize for any inconvenience this may cause and appreciate your patience and understanding as we work to resolve the issue.

Affected Services:
Affected Markets: Nigeria
Posted Jul 07, 2026 - 14:40 UTC
This incident affected: Flutterwave Collections (Collections APIs).